Forum Mac Os X server

Forum francophone sur les technologies serveur d'Apple
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Question sur Open Directory

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
kivis
AtEase 2.0
AtEase 2.0


Nombre de messages : 7
Date d'inscription : 30/05/2008

MessageSujet: Question sur Open Directory   Mer 11 Juin - 14:52

Je sais pas du tout si j'ai posté au bonne endroit , mais vu que la dernière fois on ma résolu mon problème je poste ici ( déplacé mon poste si il le faut ) thx.

Bonjour ,

J'ai des questions simples:

- Sous Microsoft un Active Directory va agir sur la base de registre de windows pour administrer un poste client . Pour mac , Open directory va agir sur quelle structure pour pouvoir garder et modifier à chaque fois les comptes sur les postes ???

- J'ai mis en place un Open Directory le problème maintenant c'est qu'après avec crée un accès Afp pour les dossiers de démarrage de chaque compte il ne m'ai plus possible de me connecter avec un compte utilisateur !! J’ai tout essayé, changer les droits sur le compte, modifier les droits de l'utilisateur rien a faire .... Le problème est inexistant en local ( connexion sur le serveur open directory directement ) .

- Est- il possible de créer un compte avec open directory et de l'utiliser sur un pc . Exemple : je me connecte d'un portable Pc je travail, je me déconnecte et me reconnecte mais sur un Mac os , c'est possible ???
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
stal87
AtEase 2.0
AtEase 2.0


Nombre de messages : 3
Date d'inscription : 12/06/2008

MessageSujet: Re: Question sur Open Directory   Jeu 3 Juil - 23:30

oui c possible.

Quel est la version de ton serveur ?

As-tu paramétré le DNS ainsi que ton open Directory ?

Donnes moi plus d'info?????
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Jeu 19 Aoû - 16:49

Perso, j'ai un soucis avec l'active directory.

Tout est paramètré : DNS (vérifié avec la commande sudo changeip -checkhostname)
Open directory paramétré en maître.

Seulement voilà, je configure mon powerbook portable pour vérifier la connection : Je place le bon DNS dans ses pref. Réseau et depuis l'utilitaire d'annuaire de ce powerbook, je vois qu'il est bien connecté au serveur.

J'ai créé un user en plus : moi-même et il y a diradmin pour l'instant dans l'annuaire.

Quand je démarre mon PowerBook (sur ma session perso , pas celle sur le domaine vu qu'elle ne s'ouvre pas), et que je désire me connecter sur le domaine créé, il me refuse systématiquement le mot de passe (pourtant correct...)

help please


Attention tout fois, après avoir activé AFP, quand je désire me connecter au serveur depuis mon PowerBook via l'onglet "connecter" et que je mets mon login et mot de passe créé, là pas de soucis, je me connecte bien aux dossiers...

Dernière précision,

Quand je veux vérifier la connection open directoy, je tape donc dscl puis, cd/LDAPv3/serveur.loverval.info/Users
puis ls

voici ce que je lis sur le terminal :

BSD
LDAPv3
Local

Contact
Search

au lieu de voir diradmin et root

Je penses qu'il y a un soucis donc...


Dernière édition par gevarra le Jeu 19 Aoû - 17:18, édité 2 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 10:19

On dirait que ton poste n'est pas relié à l'OD de ton serveur du tout en fait…
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 11:11

Pourtant, j'ai vu dans l'utilitaire d'annuaire que l'OD répondait bien...

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 11:50

Debinde-le, redémarre et recommence…

SI tu le pingues via son nom DNS il répond ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 11:51

Déblinde-le? Comment faire?

Je vais tester le ping cet après-midi. Je n'ai pas le serveur à disposition.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 11:56

Pardon pour le langage english Embarassed … Casse la liaison avec l'OD, redémarre ta machine, refais le lien, redémarre encore et vérifie que le lien soit toujours actif.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 12:02

Je déblinde le poste client ou le serveur?

J'ai trouvé ce tuto sur youtube : http://www.youtube.com/watch?v=QqdI-ELc7og

et il semble qu'il à la même réponse que moi quand il est sur le terminal du client. A savoir
"BSD
LDAPv3
Local"

Le fait que je puisse me connecter au serveur depuis ma session sur mon powerbook via 'se connecter" est bon signe? Ou cela n'a rien à voir. Je précise que là, si je place "diradmin" et mon mot de passe, là il se connecte.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 12:15

En fait, je me base sur ce wiki :

http://www.responsable.info/serveur/index.php?title=10.5_-_Configuration_des_postes_clients_pour_l%27utilisation_d%27Open_Directory

et ceci

http://www.responsable.info/serveur/index.php?title=10.5_-_Configuration_Open_Directory

Là, dès qu'il teste son OD, il voit ses diramin.

Moi je vois search contact, comme dans la vidéo.

Par hasard, cela ne serait pas un histoire de certificat ou de chiffrement de mot de passe?

Si oui, comment le paramétrer?

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 14:19

Je commence à me tirer les cheveux.....

J'ai déblidé et reconfiguré.

Bon, j'ai effectué la maneouvre expliquée dans la vidéo youtube et LA, je vois bien mes deux users créés.

DOnc, aucun prob niveau DNS et OD.

Je pense que ça vient en effet de pref du gestionnaire de groupe de travail.

Je chipote mais rien n'y fait, mes mots de passe ne sont jamais accepté par mon powerbook...

Il me semble que le chiffrement des mots de passe foire alors, mais comment faire?


Autre info : dans "Avancés" , je vois ceci :

autoriser des ouvertures simultannées sur des ordinateurs gérés. (coché)
Type de connection /bin/bash

type de mot de passe Open directory

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 16:06

Oui ça c'est ok pour moi.
Tu utilises les comptes délocalisés ou pas ?
Tu as réussi à te logguer au moins une fois sur ton serveur via un poste client ?
Tu n'as pas un compte en local qui porterais le même nom/identifiant que sur le serveur AVANT identification (ça c'est du vécu avec un AD !) ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 16:59

A la fenêtre de login quand tu cliques sous le "MacOS X" tu as bien "comptes réseau disponibles" qui apparait (il faut cliquer plusieurs fois) ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 17:56

Alors (et merci encore de te pencher sur mon problème)

Tu utilises les comptes délocalisés ou pas ?
--> Je crée les comptes via gestion de groupe. Ceux-ci se trouve donc sur LDAPv3/127.0.0.1



Tu as réussi à te logguer au moins une fois sur ton serveur via un poste client ?
Non, pas avec la boîte de dialogue au démarrage de session.
Mais uniquement de cette façon : Login via ma propre session locale sur mon powerbook, puis je vois "serveur" dans le finder et je m'y connecte par l'onglet 'connecter à". Là, je mets diradmin et je m'y connecte. Mais mon but est de me connecter via powerbook et via mes pc windows xp du réseau de mon école.

Tu n'as pas un compte en local qui porterais le même nom/identifiant que sur le serveur AVANT identification (ça c'est du vécu avec un AD !) ?
--> Compte unique pour le moment : diradmin (et le seul en local : admin) Mais par contre, ils ont les mêmes mots de passe



PS : après mes chipotages à la ***, je n'arrive plus à me logger sur le serveur via "admin", j'espère résoudre ce problème sinon, 2e reformatage en une semaine...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 18:04

Alors première chose, il ne faut pas utiliser de compte nommé "admin" sur OSX, Apple ne le recommande pas et ça m'a généré des soucis sur d'anciens OS.

Que tu arrives à toucher ton serveur en pomme-K ne signifie pas que tu es bien dans l'OD du serveur mais juste que le protocole AFP répond bien (le partage de fichiers)…

J'ai l'impression que ton poste n'est pas géré par l'OD de ton serveur… tu peux faire une copie d'écran de tes réglages OD et comptes ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 18:09

Ok, vu que je n'arrive plus à me logger à mon serveur depuis cet aprèm (après mes chipotages pour résoudre ce soucis d'OD), je vais le réinstaller et travailler avec autre chose qu'admin donc...

Pour ce qui est de la copie d'écran. Je te fais ça.

Peux-tu me dire si je peux (dans le sens "recommandé") installer le serveur chez moi ce week end et le configurer avec l'adresse IP de mon routeur perso? Si lundi, je le replace dans l'environnement de mon école et que je change son IP, cela créera des instabilités?
Si oui, je fais l'install et la config ça sera pour lundi


Dès que je peux, donc, je te fais les copies d'écran.

Super (si tu passes en Belgique, je t"offre un coup à boire Wink)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 18:17

Perso quand je fais des install sur un autre site, je crée un réseau virtuel sur mon Mac Client qui accède en direct sur le serveur qui comme cela a directement sa bonne config, j'aime pas trop jouer au jeu du changement d'IP/DNS même si logiquement ça devrait bien marcher, les anciennes versions d'OS X Server m'ont laissé un goût amer dans la bouche et du coup je prend pas mal de précaution surement plus indispensables mais qui ne me coûtent pas plus cher Very Happy

Je suis à Lille ce WE, pas si loin que ça de la Belgique Razz
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 18:23

Clairement, je pensais aussi que cela n'était pas super prudent.

Donc ce week end --> Réinstall system puis lundi sur le réseau, config.

Sur le wiki que j'ai suivi, il préconisait de cocher "enregistrer les users plus tard" au lieu de créer "maintenant les users". N'est-il pas préférable de cocher la seconde? (dans le wiki, il disait de cocher enregistrer les users pluis tard" (simple question)

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 18:25

Autre question (ne suis-je pas trop chiant??)

En fait, me connecter avec mon powerbook n'est qu'un test perso. Ne crois-tu pas que je vais galerer pour faire entrer mes pc win xp dans l'OD du mac os?
Vu que ça coince déjà avec un mac client, j'espère que cela sera possible... (SMB actif bien entendu)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 18:28

Tu peux rentrer tes PC dans ton OD sans souci mais effectivement rentre déjà tes MAC Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 18:31

Je me suis dit la même chose. Dès que j'ai trouvé la bonne config pour que mon powerbook s'y connecte à l'aise, je réfléchirais ensuite pour les pc...

Pour toi, je dois chercher du côté réglage de l'OD et des comptes users donc
Tu m'as parlé du Keyberos, y-a-til des paramètres à modifier selon toi?


PS :

Sur le wiki que j'ai suivi, il préconisait de cocher "enregistrer les users plus tard" au lieu de créer "maintenant les users" lors de l'install. N'est-il pas préférable de cocher la seconde? (dans le wiki, il disait de cocher enregistrer les users pluis tard" (simple question)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Ven 20 Aoû - 23:56

Une piste peut être,

j'ai lu sur un forum qu'il faut impérativement configurer le dossier "home" pour chaque users, chose que je n'ai pas faite.
De plus, je n'ai pas activé le server DHCP de mon serveur, en pensant laisser les IP fixes sur les machines. Mais j'ai lu que si le DHCP est activé et qu'on est en dynamique, cela facilitait le "raccord" avec l'OD


Non? Je teste lundi
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Question sur Open Directory   Mar 24 Aoû - 11:16

Perso je suis en IP fixe et pas de souci d'OD par contre je suis en compte mobile délocalisé…
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Mer 25 Aoû - 11:42

Bon voilà, cela marche.

Le problème venait des homes directories que je n'avais pas parametré

Donc, mon powerbook entre bien dans le domaine, je m'attaque à mes PC.

Je sens que je vais suer...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gevarra
Serveur X 10.4
Serveur X 10.4


Nombre de messages : 393
Date d'inscription : 06/01/2010

MessageSujet: Re: Question sur Open Directory   Mer 25 Aoû - 11:57

Bon, il ne m'a pas fallu longtemps pour avoir un problème avec un win xp.

Donc, quand je veux mettre le pc dans le domaine via système, ID Réseau,
j'active préalablement SMB (en controleur du domaine principal). J'affecte le nom de domaine (idem que celui DNS)
et sur mon xp, il me donne un message d'erreur : "ressources système insuffisantes pour terminer le travail demandé"

...

Faut-il configurer l'onglet "windows" dans le gestionnaire des groupes de travail?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Question sur Open Directory   

Revenir en haut Aller en bas
 
Question sur Open Directory
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant
 Sujets similaires
-
» le tchat question
» j'ai deux question qui m'intrigue
» question par un nul du GPS
» Question basique
» La question du graphiste geek soucieux de ses lombaires

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum Mac Os X server :: Services de fichiers-
Sauter vers: