Forum Mac Os X server

Forum francophone sur les technologies serveur d'Apple
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 impossible d'envoyer un mel via IMAP

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 0:43

Bonjour à tous,

ma configuration : MacOS X Serveur 10.4.8

Mon souci : impossible via Entourage d'envoyer un mel depuis mon compte en IMAP, j'ai le message "Relay Access Denied" alors que j'arrive à envoyer et à recevoir d'un compte POP->IMAP - D'un compte IMAP->IMAP - D'un compte Exchange->IMAP sans problème…
Autrement dit, avec ma config, je peux "rentrer" des mels mais pas en "sortir"…

Autre chose qui vous aidera peut-être, si je passe par le webmail de mon serveur et que j'essaye de m'envoyer un mail sur un compte pop, je le reçois bien par contre la fenêtre webmail d'envoi est toujours présente te je n'ai rien dans mes éléments envoyés, on dirait que le serveur ne capte pas que le mel est passé ??

Si quelqu'un pouvait m'aider à configurer convenablement mon serveur, ça serait super sympa car je pense que j'ai dû me planter quelque part mais où ????

Merci de votre aide.
Franck.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Alex_
Admin


Nombre de messages : 442
Localisation : Nantes_Fr
Date d'inscription : 13/11/2005

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 10:31

Bonjour Franck

pourrais-tu nous envoyer le résultat de
Code:
postconf -n
- dans le terminal- afin que je puisse jeter un coup d'oeil sur ta config stp.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.erba-nantes.fr
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 12:41

Citation :
tiger_serveur:~ admin$ postconf -n
alias_maps = hash:/etc/aliases,hash:/var/mailman/data/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
enable_server_options = yes
html_directory = no
inet_interfaces = all
local_recipient_maps =
luser_relay = postmaster
mail_owner = postfix
mailbox_size_limit = 0
mailbox_transport = cyrus
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
message_size_limit = 0
mydestination = $myhostname,localhost.$mydomain,tigerserver.com,login.hd.free.fr
mydomain = at-login.com
mydomain_fallback = localhost
myhostname = at-login.com
mynetworks = 127.0.0.0/8
mynetworks_style = host
newaliases_path = /usr/bin/newaliases
owner_request_special = no
queue_directory = /private/var/spool/postfix
readme_directory = /usr/share/doc/postfix
recipient_delimiter = +
relayhost =
sample_directory = /usr/share/doc/postfix/examples
sendmail_path = /usr/sbin/sendmail
setgid_group = postdrop
smtpd_pw_server_security_options = none
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination,permit
smtpd_sasl_auth_enable = no
smtpd_tls_key_file =
smtpd_use_pw_server = no
unknown_local_recipient_reject_code = 550
virtual_mailbox_domains = hash:/etc/postfix/virtual_domains
virtual_transport = lmtp:unix:/var/imap/socket/lmtp

Un truc étrange, mon nom de domaine est at-login.com et je vois encore une trace de l'ancien qui était login.hd.free.fr ça vient peut-être de là ?

Merci de ton aide en tout cas...

[edit] ok, login.hd.free.fr apparait car il doit s'agir de mes réglages d'hôtes virtuels comme tigerserver.com, faudra que je vire ça... cheers
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Alex_
Admin


Nombre de messages : 442
Localisation : Nantes_Fr
Date d'inscription : 13/11/2005

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 13:25

Pour moi…


mydestination = $myhostname,localhost.$mydomain,tigerserver.com,login.hd.free.fr
mydomain = at-login.com
mydomain_fallback = localhost
myhostname = mailserver.at-login.com
mynetworks = 127.0.0.0/8,xxx.xxx.xxx.xxx

où xxx.xxx.xxx.xxx est l'ip de ton serveur
et mailserver.at-login.com le nom FQDN de ton serveur

fais effectivement le nettoyage dans mydestination =

par contre, j'attire ton attention sur le fait que le serveur doit avoir un nom DNS résolu…
c'est extremement important; pas la peine d'aller plus loin dans la config si cette première étape n'est pas vérifiée;

sur le serveur, dans terminal si tu tapes :
Code:
hostname
il doit te retourner mailserver.at-login.com

et si tu entres
Code:
host  xxx.xxx.xxx.xxx

où xxx.xxx.xxx.xxx est toujours l'ip de ton serveur
il doit te retourner encore mailserver.at-login.com

dis nous tout
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.erba-nantes.fr
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 13:52

Je n'arrive pas à changer ces paramètres, bizarrement l'ancien nom de mon serveur est toujours présent mais pas dans l'interface Admin Serveur de MacOS X…

Il va falloir que je modifie à la main le fichier dans le Terminal, c'est lequel à modifier excatement ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 15:12

hostname me retourne le nom Tiger_Serveur.com
alors que
host monip me retourne bien mon nom de domaine (at-login.com)

gné ? Question
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Alex_
Admin


Nombre de messages : 442
Localisation : Nantes_Fr
Date d'inscription : 13/11/2005

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 15:36

Citation :
Il va falloir que je modifie à la main le fichier dans le Terminal, c'est lequel à modifier excatement ?

c'est dans /etc/postfix , le fichier se nomme main.cf


Citation :
hostname me retourne le nom Tiger_Serveur.com
alors que
host monip me retourne bien mon nom de domaine (at-login.com)

aie, c'est pas gagné :
monip me retourne bien mon nom de domaine : il devrait te retourner le nom de ta machine en FQDN : i.e. mailserver.at-login.com

essaye aussi de changer le hostname de ton serveur :
dans terminal :

Code:
hostname mailserver.at-login.com
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.erba-nantes.fr
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 15:36

[edit] ok, j'ai bien mis le nom de domaine dans myhostname en faisant :

Code:
sudo hostname mailserver.at-login.com

ça, ça roule mais ça ne pas fais évoluer mon souci... Je m'attaque à la modification de l'IP...

Excellent : nos 2 posts se sont croisés cheers
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 16:27

Quand je parle de mon IP, je parle de mon IP LAN pas de mon IP WAN… Je t'ai peut-être fourvoyé là, non ? No
ho purée ! Je touche mon Serveur via ARD, je tente d'établir une connexion internet (surf) depuis mon serveur et il me retourne une erreur comme quoi il n'est pas connecté au net…
Là, j'ai les boules, ça expliquerait pourquoi je n'arrive pas à envoyer (relay access Denied) non ?
Mais alors comment se fait-il que je puisse recevoir des mels depuis l'extérieur sur mon serveur ?
Sleep
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 16:58

Purée ! Je retape hostname et il me redonne tiger_serveur.test confused

On dirait qu'aucune modif n'est prise ne compte, je ne comprends pas j'ai tout installé nickel, formattage et tout le toutim...

[edit], bon j'ai stoppé Postfix, je refais hostname mailserver.at-login.com et je reloadé la config postfix, cette fois il me répond bien mailserver.at-login.com quand je fais hostname cheers

Bon, au niveau de l'envoi de mel, ça marche toujours pas par contre... Evil or Very Mad
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 17:06

Chose étrange, quand je fais postconf -n, j'obtiens myhostname = at-login.com et non pas mailserver.at-login.com silent
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 17:31

Je vais arrêter de vous embêter et de polluer ce forum, est-ce que quelqu'un pourrait me poster des images de sa configuration Admin Serveur svp ?

J'ai forcément dû me planter quelque part et je sens que je vais mettre du temps à trouver...

ça serait super sympa...

pale
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Alex_
Admin


Nombre de messages : 442
Localisation : Nantes_Fr
Date d'inscription : 13/11/2005

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 17:48

Franck, pas de pb, le forum est fait pour ça…

simplement, je crois qu'il te faut aplanir les questions dns avant toute chose :

1) ton serveur doit être visible depuis internet :
-> a-t-il une ip publique ou est-il sur une DMZ ?

2) l'ip publique doit correspondre à un nom de domaine
avec récursion du nom de domaine xxx.xxx.xxx.xxx <-> nomserver.nomdedomaine.ext

3) chez ton registrar, ton serveur doit être déclaré en tant qu'hote mail (MX)

ce n'est qu'une fois toutes ces conditions remplies que tu peux configurer le serveur mail…

quelle est donc ta config au vue de ces 3 critères ?

@+


Dernière édition par le Lun 9 Oct - 19:00, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.erba-nantes.fr
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 17:53

OK, je continue donc (vous l'aurez voulu bom )...

J'ai donc une IP fixe, j'ai acheté un nom de domaine que j'ai fait pointer sur mon IP fixe (chez moi), sur mon routeur, j'ai mappé les ports afin que le poste serveur soit "touchable".

Je n'ai aucune problème pour accéder en ftp ou via le webmail ou encore accéder à mes comptes en IMAP depuis l'extérieur.

Je me renseigne chez mon registar pour le MX...


Dernière édition par le Lun 9 Oct - 19:13, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Lun 9 Oct - 18:11

Mon registar me dit que je dois créer un sous-domaine et qu'ensuite je dois faire pointer mon MX sur mon sous-domaine, ça vous semble cohérent ?
Je pensais que je pouvais tout faire à partir de mon nom de domaine ?

[edit] ok je suis un âne : mailserver.at-login.com était le fameux sous-domaine à créer, je pensais que mailserver était "pré-cablé" dans OSX Serveur...

Désolé si je ne commute pas vite, je ne suis pas bien habitué à ce type de manip'...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Mar 10 Oct - 12:30

voici ce que la commande dig me donne sur mon nom de domaine

Code:
; <<>> DiG 9.2.2 <<>> at-login.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37974
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;at-login.com.                  IN      A

;; ANSWER SECTION:
at-login.com.          86088  IN      A      81.56.227.25

;; Query time: 6 msec
;; SERVER: 10.150.2.213#53(10.150.2.213)
;; WHEN: Tue Oct 10 11:25:14 2006
;; MSG SIZE  rcvd: 46

Par contre je suis obligé d'avoir un sous-domaine ???
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3030
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: impossible d'envoyer un mel via IMAP   Mar 10 Oct - 16:55

Alors, j'ai fini par trouver un astuce, c'est de me servir du smtp de mon FAI en tant que relais sortant sur OSX Serveur, ce qui fait que mon webmail fonctionne Nickel Wink et je me sers toujours du smtp de mon FAI pour envoyer depuis Entourage...

Donc ça tourne plutôt pas mal...

Merci de votre aide à tous,
Je continue de squatter les forums lol!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: impossible d'envoyer un mel via IMAP   

Revenir en haut Aller en bas
 
impossible d'envoyer un mel via IMAP
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» HELP impossible d'envoyer un seul mp
» [Bug] Impossible d'envoyer des mp à un groupe
» Impossible d'envoyer un MP sur ce forum
» Impossible d'envoyer des messages privés
» Impossible d'envoyer des MP

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum Mac Os X server :: Services mail-
Sauter vers: