Forum Mac Os X server

Forum francophone sur les technologies serveur d'Apple
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Kerberos ne démarre pas

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Kerberos ne démarre pas   Ven 27 Jan - 14:39

Bonjour,

Je suis en train d'aider un copain à configurer un MacMini équipé de Leopard Server. Il me semble avoir bien configuré le service dns, les quelques tests semblent concluants. J'ai démarré l'opendirectory en maître mais kerberos refuse de démarrer.
Vous auriez une piste ?
Merci
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 15:53

Oui : les DNS cheers

Regarde sur les forums, j'ai développé un outil qui pourrait t'aider à vérifier tes DNS…
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 15:58

Franck Mereo (zekiller28) a écrit:
Oui : les DNS cheers

Regarde sur les forums, j'ai développé un outil qui pourrait t'aider à vérifier tes DNS…
Pourtant, mes dns me semblent fonctionner correctement. Je vais voir ton outil. Merci !
Ah mince. C'est de PowerMailServer dont tu parles ? Je n'ai pas de Mac OS 10.6 server. Là, il s'agit d'un MacMini G4 avec un 10.5 Server.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:20

Lorsque je fais un sudo changeip -checkhostname j'ai bien l'adresse IP locale pour la Primary adress, le bon serveur (macmini.___.local) pour le Current HostName et pour le DNS HostName.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:22

Ha… Tu es en 10.5 ? Un conseil si tu peux : passe en 10.6… Et encore un conseil : ne passe pas en 10.7 !!!

Tu as bien mis ton serveur dans ses propres DNS réseau ?

Arrives-tu à pinguer ton serveur via un poste client en utilisant son nom DNS ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:28

Oui, je suis en 10.5. Mon copain a acheté ce MacMini avec un 10.5 Server et je ne pense pas qu'il veuille acheter une machine plus récente.
Le serveur DNS est bien renseigné dans ses propres DNS.
Depuis un poste distant sur le même réseau, avec un MacBook Pro sous 10.6.8 par exemple, si je ne mets que l'adresse du MacMini dans les entrées DNS, je sors bien du réseau local pour aller explorer le vaste monde.
Le ping marche du tonnerre de Zeus !


PING macmini.___.local (100.0.0.254): 56 data bytes
64 bytes from 100.0.0.254: icmp_seq=0 ttl=64 time=1.096 ms
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:30

Ha oui c'est un G4, j'avais pas vu…
Tu as bien renseigné ton OD ?
Ton hostname te renvoie quoi dans le Terminal ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:38

Le hostname me renvoie macmini.___.local

Pour l'OD, je n'ai pas renseigné grand chose la base de recherche de LDAP est dc=macmini,dc=____,dc=local
Par contre, maintenant que tu m'incites à regarder de ce côté, je m'aperçois que je n'ai pas de bouton pour arrêter ou démarrer Open Directory. Etrange, non ?

Apparemment, il est bien Maître Open Directory.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:39

bizarre ton nom DNS tout de même… C'est quoi tous ces underscore ???

Tu ne peux pas arrêter un OD, c'est normal.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:45

Les underscore, c'est rien. C'est juste pour masquer le nom de mon copain. Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:46

Ha ok… J'ai eu peur ! Very Happy
Tu as honte de donner son nom ?? Embarassed rendeer
Tu as redémarré ton serveur ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:50

Il a un nom particulièrement ridicule et c'est par bonté d'âme que je le cache.
J'ai redémarré le serveur au moins trois fois.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:59

Allez ! Balance qu'on se marre Laughing

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 16:59

Je viens de tester quelque chose qui me laisse pantois. J'ai créé un compte utilisateur et j'arrive très bien à me connecter à ce compte depuis le MacBook Pro. C'est à dire que j'ouvre le compte créé sur le serveur depuis une machine distante. C'est bien que Open Directory fonctionne, non ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:00

Oui mais Open Directory et Kerberos sont 2 choses différentes…
Donc ton OD fonctionne effectivement…
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:02

Franck Mereo (zekiller28) a écrit:
Allez ! Balance qu'on se marre Laughing

Oh bah j'ai promis ! En fait, le nom n'est pas si ridicule que ça mais le copain est un peu parano.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:03

Ok je n'insiste pas (pour cette fois Smile )…
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:04

Franck Mereo (zekiller28) a écrit:
Oui mais Open Directory et Kerberos sont 2 choses différentes…
Donc ton OD fonctionne effectivement…
D'accord. Pour moi, ça fonctionnait ensemble. Ceci dit, j'ai déjà configuré quelques Mac OS 10 Server (10.4 et 10.5) sans jamais trop me soucier de kerberos qui, me semble-t-il, démarrait sans que je m'en occupe. Du reste, je ne vois rien où m'occuper de ce kerberos.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:05

Franck Mereo (zekiller28) a écrit:
Ok je n'insiste pas (pour cette fois Smile )…
S'il ne me rend pas le petit service qu'il me doit en échange du coup de main que je lui donne, je balance son nom ! Twisted Evil
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:26

Je pense avoir mis le doigt sur le coupable ! Ce qui m'a mis la puce à l'oreille, c'est d'avoir dit avoir configuré plusieurs Mac OS X Server et de n'avoir jamais rencontré ce souci. Et là, j'ai cherché la différence. Celle que j'ai tout de suite trouvée est dans le nom dns qui se termine en .local.
Je fais une recherche sur Internet et je pense avoir trouvé une réponse
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:35

Oui Kerberos et OD sont liés… maintenant on peut se servir d'OD sans Kerberos (mais ça dépend des Services utilisés en fait)…

Tiens donc tu aurais un souci de DNS ? Razz
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:41

Franck Mereo (zekiller28) a écrit:
Oui Kerberos et OD sont liés… maintenant on peut se servir d'OD sans Kerberos (mais ça dépend des Services utilisés en fait)…

Tiens donc tu aurais un souci de DNS ? Razz
C'est qu'il ne faut jamais utilisé de .local dans les noms dns ? Franchement, je ne le savais pas. C'est mon copain qui m'a suggéré cela...
Maintenant, il faut que je voie s'il est possible de changer cela sans tout casser.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:44

ha non effectivement… Il vaut mieux privilégier les .prive
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
bird
Serveur X 10.4
Serveur X 10.4
avatar

Nombre de messages : 162
Localisation : Azerat-Dordogne-Aquitaine-France-Europe-Planète terre
Date d'inscription : 07/04/2008

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:47

Franck Mereo (zekiller28) a écrit:
ha non effectivement… Il vaut mieux privilégier les .prive
Je me coucherai un peu moins bête. Merci pour tout, n'empêche !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://mloiseau.free.fr/blog
Franck Mereo (zekiller28)
Admin
avatar

Nombre de messages : 3039
Age : 43
Localisation : Paris
Date d'inscription : 09/10/2006

MessageSujet: Re: Kerberos ne démarre pas   Ven 27 Jan - 17:47

Je suis désolé, je n'avais pas prêté attention au suffixe que tu avais utilisé…
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Kerberos ne démarre pas   

Revenir en haut Aller en bas
 
Kerberos ne démarre pas
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant
 Sujets similaires
-
» [Résolu] PC Packard Bell ne démarre plus
» Mon ordinateur Windows Xp redémarre tout seul
» Bbox qui redémarre toute seule
» bBoxTV qui redémarre sans fin avec un horrible bruit métallique...
» Bug Bbox TV qui redémarre en lecture via média center

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum Mac Os X server :: Installation Os X serveur-
Sauter vers: